aboutsummaryrefslogtreecommitdiff
path: root/examples/intel-quark-d2000/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-07-27 11:45:12 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-07-27 19:28:29 +0200
commit7ab005681a15ef2f4b60d8fce866731aa028f7b9 (patch)
treee2d27e116defcdd8a3d9eac9b3db7408416fdfbc /examples/intel-quark-d2000/CMakeLists.txt
parenta8256910d40a0eee85bf539a3f120c9d92485f3f (diff)
downloadkicad-utils-7ab005681a15ef2f4b60d8fce866731aa028f7b9.tar.gz
kicad-utils-7ab005681a15ef2f4b60d8fce866731aa028f7b9.tar.bz2
kicad-utils-7ab005681a15ef2f4b60d8fce866731aa028f7b9.tar.xz
kicad-utils-7ab005681a15ef2f4b60d8fce866731aa028f7b9.zip
o Support for Intel Quark D2000 chip.
Diffstat (limited to 'examples/intel-quark-d2000/CMakeLists.txt')
-rw-r--r--examples/intel-quark-d2000/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/examples/intel-quark-d2000/CMakeLists.txt b/examples/intel-quark-d2000/CMakeLists.txt
new file mode 100644
index 0000000..4c0ef68
--- /dev/null
+++ b/examples/intel-quark-d2000/CMakeLists.txt
@@ -0,0 +1,13 @@
+kicad_gen(
+ TARGET schematic.h
+ NET schematic/intel-quark-d2000.net
+ REF U1)
+
+if (FALSE)
+ # If you have Intel Quark support for CMake something like this would work:
+
+ #add_executable(arduino-led arduino-led.ino schematic.h)
+ #target_include_directories(arduino-led PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/kicad-include)
+else ()
+ add_custom_target(intel-quark-d2000 ALL DEPENDS schematic.h)
+endif ()