aboutsummaryrefslogtreecommitdiff
path: root/examples/intel-quark-d2000/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/intel-quark-d2000/CMakeLists.txt')
-rw-r--r--examples/intel-quark-d2000/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/examples/intel-quark-d2000/CMakeLists.txt b/examples/intel-quark-d2000/CMakeLists.txt
new file mode 100644
index 0000000..4c0ef68
--- /dev/null
+++ b/examples/intel-quark-d2000/CMakeLists.txt
@@ -0,0 +1,13 @@
+kicad_gen(
+ TARGET schematic.h
+ NET schematic/intel-quark-d2000.net
+ REF U1)
+
+if (FALSE)
+ # If you have Intel Quark support for CMake something like this would work:
+
+ #add_executable(arduino-led arduino-led.ino schematic.h)
+ #target_include_directories(arduino-led PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/kicad-include)
+else ()
+ add_custom_target(intel-quark-d2000 ALL DEPENDS schematic.h)
+endif ()