aboutsummaryrefslogtreecommitdiff
path: root/examples/intel-quark-d2000/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2016-08-01 08:20:23 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2016-08-01 08:20:23 +0200
commitbfeeac6e4889d1e9a1083b3c7efc59652981b168 (patch)
treea937d844a59da7c509685dcd1ddd9933772e526f /examples/intel-quark-d2000/CMakeLists.txt
parentc307e9f234e544386fa3ae53083c7510668e1716 (diff)
downloadkicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.gz
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.bz2
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.tar.xz
kicad-utils-bfeeac6e4889d1e9a1083b3c7efc59652981b168.zip
o Moving the generation logic to Python, embedding a Python interpreter with the help of pybind11.
o Adding install configuration to CMake to make it easier to reuse the project later on. o Splitting out the examples into its own project to make it easier to test the whole installation setup and python/template loading. o Trying to reorganize the code a bit, not very much better yet.
Diffstat (limited to 'examples/intel-quark-d2000/CMakeLists.txt')
-rw-r--r--examples/intel-quark-d2000/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/examples/intel-quark-d2000/CMakeLists.txt b/examples/intel-quark-d2000/CMakeLists.txt
index 1822996..3920d4b 100644
--- a/examples/intel-quark-d2000/CMakeLists.txt
+++ b/examples/intel-quark-d2000/CMakeLists.txt
@@ -1,8 +1,11 @@
+find_package(KicadUtils)
+
kicad_generate_header(
OUTPUT schematic.h
NET schematic/intel-quark-d2000.net
REF U1
- IN_SOURCE)
+ TEMPLATE intel-quark-d2000.py
+ TEMPLATE_LIB_LIST .)
if (FALSE)
# If you have Intel Quark support for CMake something like this would work:
@@ -10,5 +13,5 @@ if (FALSE)
#add_executable(arduino-led arduino-led.ino schematic.h)
#target_include_directories(arduino-led PUBLIC ${CMAKE_CURRENT_BINARY_DIR}/kicad-include)
else ()
- add_custom_target(intel-quark-d2000 ALL DEPENDS schematic.h)
+ add_custom_target(intel-quark-d2000 ALL DEPENDS schematic.h schematic-py.h)
endif ()