summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTrygve Laugstøl <trygvis@inamo.no>2017-06-06 09:11:22 +0200
committerTrygve Laugstøl <trygvis@inamo.no>2017-06-06 09:11:22 +0200
commit1729acd9b72369af45ee5ed45a8d29642f3df367 (patch)
tree652f3f679b27287c9be6d3ea0676188f87fa5f33 /test/CMakeLists.txt
parent4ee01dab6105e346b731a13321a3e6a5d111d3e4 (diff)
downloadradio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.tar.gz
radio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.tar.bz2
radio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.tar.xz
radio-controller-1729acd9b72369af45ee5ed45a8d29642f3df367.zip
wip
o Dropping Samsung-specific code, will be replaces by a small script. o Starting on some unit test code.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..4a51fd4
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.6)
+project(radio-controller-test CXX)
+
+add_executable(tests
+ tests.cpp
+ catch.hpp
+
+ ../include
+
+ bit_string-test.cpp
+ ../include/decoder.h
+ ../include/misc.h
+ ../include/script_decoder.h
+ )