summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..4a51fd4
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.6)
+project(radio-controller-test CXX)
+
+add_executable(tests
+ tests.cpp
+ catch.hpp
+
+ ../include
+
+ bit_string-test.cpp
+ ../include/decoder.h
+ ../include/misc.h
+ ../include/script_decoder.h
+ )