summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 06:54:56 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-17 11:42:48 -0800
commit0091e59d2a18c293fd952a9d707e609afdd6b17f (patch)
tree094899126558e846013a46379920af51a1a55313 /configure.in
parent94975c96d4f1f614e0877cac32ed5949cd0235f6 (diff)
downloadopenocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.tar.gz
openocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.tar.bz2
openocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.tar.xz
openocd+libswd-0091e59d2a18c293fd952a9d707e609afdd6b17f.zip
allow documentation to be configured
Add --disable-doxygen-html and --enable-doxygen-pdf options to the configure script, allowing user to change the defaults. These update the proess of munging the Doxygen configuration file to use the settings thusly provided. Add options in README.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa2a4985..8ba89512 100644
--- a/configure.in
+++ b/configure.in
@@ -277,6 +277,24 @@ AC_ARG_WITH(ftd2xx-lib,
with_ftd2xx_lib=static
])
+
+AC_ARG_ENABLE(doxygen-html,
+ AS_HELP_STRING([--disable-doxygen-html],
+ [Disable building Doxygen manual as HTML.]),
+ [doxygen_as_html=$enableval], [doxygen_as_html=yes])
+AC_SUBST(doxygen_as_html)
+AC_MSG_CHECKING([whether to build Doxygen as HTML])
+AC_MSG_RESULT($doxygen_as_html)
+
+AC_ARG_ENABLE(doxygen-pdf,
+ AS_HELP_STRING([--enable-doxygen-pdf],
+ [Enable building Doxygen manual as PDF.]),
+ [doxygen_as_pdf=$enableval], [doxygen_as_pdf=no])
+AC_SUBST(doxygen_as_pdf)
+AC_MSG_CHECKING([whether to build Doxygen as PDF])
+AC_MSG_RESULT($doxygen_as_pdf)
+
+
AC_ARG_ENABLE(gccwarnings,
AS_HELP_STRING([--disable-gccwarnings], [Disable compiler warnings]),
[gcc_warnings=$enableval], [gcc_warnings=yes])