summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-27 13:47:36 +0000
committerduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-27 13:47:36 +0000
commit2e3095f8e69162a23b042d643900d2aa9ee7276f (patch)
tree51aaf05a04b7dc4cc0ed0b043a77e9b363d9cf2f /configure.in
parent274b3a56ef018f5689d85ed69b4c37218984bc05 (diff)
downloadopenocd+libswd-2e3095f8e69162a23b042d643900d2aa9ee7276f.tar.gz
openocd+libswd-2e3095f8e69162a23b042d643900d2aa9ee7276f.tar.bz2
openocd+libswd-2e3095f8e69162a23b042d643900d2aa9ee7276f.tar.xz
openocd+libswd-2e3095f8e69162a23b042d643900d2aa9ee7276f.zip
Missed support for without --exec-prefix and ftd2xx stuff
git-svn-id: svn://svn.berlios.de/openocd/trunk@1283 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 16 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8f3bbdf1..3681da95 100644
--- a/configure.in
+++ b/configure.in
@@ -36,15 +36,28 @@ is_win32=no
# And - if we are being installed there - the odds are
# The libraries unique to what we are are there too.
#
+
+# Expand nd deal with NONE - just like configure will do later
+OCDprefix=$prefix
+OCDxprefix=$exec_prefix
+test x"$OCDprefix" = xNONE && OCDprefix=$ac_default_prefix
+# Let make expand exec_prefix.
+test x"$OCDxprefix" = xNONE && OCDxprefix="$OCDprefix"
+
+
# what matters is the "exec-prefix"
-if test $exec_prefix != $ac_default_prefix
+if test "$OCDxprefix" != "$ac_default_prefix"
then
+ # We are installing in a non-standard place
+ # Nonstandard --prefix and/or --exec-prefix
+ # We have an override of some sort.
# use build specific install library dir
- LDFLAGS="$LDFLAGS -L$libdir"
+
+ LDFLAGS="$LDFLAGS -L$OCDxprefix/lib"
# RPATH becomes an issue on Linux only
if test $host_os = linux-gnu
then
- LDFLAGS="$LDFLAGS -Wl,-rpath,$libdir"
+ LDFLAGS="$LDFLAGS -Wl,-rpath,$OCDxprefix/lib"
fi
# The "INCDIR" is also usable
CFLAGS="$CFLAGS -I$includedir"