summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 16 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 8f3bbdf1..3681da95 100644
--- a/configure.in
+++ b/configure.in
@@ -36,15 +36,28 @@ is_win32=no
# And - if we are being installed there - the odds are
# The libraries unique to what we are are there too.
#
+
+# Expand nd deal with NONE - just like configure will do later
+OCDprefix=$prefix
+OCDxprefix=$exec_prefix
+test x"$OCDprefix" = xNONE && OCDprefix=$ac_default_prefix
+# Let make expand exec_prefix.
+test x"$OCDxprefix" = xNONE && OCDxprefix="$OCDprefix"
+
+
# what matters is the "exec-prefix"
-if test $exec_prefix != $ac_default_prefix
+if test "$OCDxprefix" != "$ac_default_prefix"
then
+ # We are installing in a non-standard place
+ # Nonstandard --prefix and/or --exec-prefix
+ # We have an override of some sort.
# use build specific install library dir
- LDFLAGS="$LDFLAGS -L$libdir"
+
+ LDFLAGS="$LDFLAGS -L$OCDxprefix/lib"
# RPATH becomes an issue on Linux only
if test $host_os = linux-gnu
then
- LDFLAGS="$LDFLAGS -Wl,-rpath,$libdir"
+ LDFLAGS="$LDFLAGS -Wl,-rpath,$OCDxprefix/lib"
fi
# The "INCDIR" is also usable
CFLAGS="$CFLAGS -I$includedir"