summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-27 15:00:36 +0000
committerduane <duane@b42882b7-edfa-0310-969c-e2dbd0fdcd60>2008-12-27 15:00:36 +0000
commitaae70f0a46e3e50f93627d11141325cfebd762f5 (patch)
tree925bb2828995dc438a9bab16bd51b859c7d354ca /configure.in
parent2e3095f8e69162a23b042d643900d2aa9ee7276f (diff)
downloadopenocd+libswd-aae70f0a46e3e50f93627d11141325cfebd762f5.tar.gz
openocd+libswd-aae70f0a46e3e50f93627d11141325cfebd762f5.tar.bz2
openocd+libswd-aae70f0a46e3e50f93627d11141325cfebd762f5.tar.xz
openocd+libswd-aae70f0a46e3e50f93627d11141325cfebd762f5.zip
Some systems report linux as host, others linux-gnu... grrr
git-svn-id: svn://svn.berlios.de/openocd/trunk@1284 b42882b7-edfa-0310-969c-e2dbd0fdcd60
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3681da95..638a73f7 100644
--- a/configure.in
+++ b/configure.in
@@ -55,7 +55,7 @@ then
LDFLAGS="$LDFLAGS -L$OCDxprefix/lib"
# RPATH becomes an issue on Linux only
- if test $host_os = linux-gnu
+ if test $host_os = linux-gnu || $host_os = linux
then
LDFLAGS="$LDFLAGS -Wl,-rpath,$OCDxprefix/lib"
fi
@@ -500,7 +500,7 @@ if test $build_ft2232_ftd2xx = yes ; then
AC_MSG_CHECKING([for libftd2xx.a (linux)])
# Must be linux -
# Cause FTDICHIP does not supply a MAC-OS version
- if test $host_os != linux-gnu; then
+ if test $host_os != linux-gnu && $host_os != linux ; then
AC_MSG_ERROR([The (linux) ftd2xx library from FTDICHIP.com is linux only. Try --enable-ft2232-libftdi instead])
fi
# Are we given a TAR directory?