summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 09:15:09 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-18 07:22:22 -0800
commit5e229bbf87fbb5a809553526edf0186dd3dd5cf8 (patch)
tree4abbfa0e0deeccbd2ae0052df247d8743548496d /src/Makefile.am
parentcb7dbc1af41068f826246beb53870c01d8973bb8 (diff)
downloadopenocd+libswd-5e229bbf87fbb5a809553526edf0186dd3dd5cf8.tar.gz
openocd+libswd-5e229bbf87fbb5a809553526edf0186dd3dd5cf8.tar.bz2
openocd+libswd-5e229bbf87fbb5a809553526edf0186dd3dd5cf8.tar.xz
openocd+libswd-5e229bbf87fbb5a809553526edf0186dd3dd5cf8.zip
pass startup_tcl to command_init
Removes external linkage from helper module, making the startup code a parameter to a new command context's initialization routine.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7a886811..8f96b053 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -116,7 +116,7 @@ BIN2C = $(builddir)/helper/bin2char$(EXEEXT_FOR_BUILD)
# Convert .tcl to cfile
startup_tcl.c: startup.tcl $(BIN2C)
- $(BIN2C) startup_tcl < $< > $@ || rm -f $@
+ $(BIN2C) openocd_startup_tcl < $< > $@ || rm -f $@
# add startup_tcl.c to make clean list
CLEANFILES = startup.tcl startup_tcl.c