summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 08:29:20 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-18 07:21:42 -0800
commitcb7dbc1af41068f826246beb53870c01d8973bb8 (patch)
treeb32165dedbf769d667d0a3deeb86e4183f1bfb9e /src/Makefile.am
parent903daa796a226152fe56245758c8388b79d12988 (diff)
downloadopenocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.tar.gz
openocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.tar.bz2
openocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.tar.xz
openocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.zip
split startup.tcl file across modules
Moves definitions for each layer into their own file, eliminating layering violations in the built-in TCL code. Updates src/Makefile.am rules to include all files in the final startup.tcl input file, and others Makefile.am rules to distribute the new files in our packages.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2f17ba4d..7a886811 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -99,7 +99,11 @@ libopenocd_la_LIBADD += -lmicrohttpd
endif
STARTUP_TCL_SRCS = \
- $(srcdir)/helper/startup.tcl
+ $(srcdir)/helper/startup.tcl \
+ $(srcdir)/jtag/startup.tcl \
+ $(srcdir)/target/startup.tcl \
+ $(srcdir)/flash/startup.tcl \
+ $(srcdir)/server/startup.tcl
EXTRA_DIST = $(STARTUP_TCL_SRCS)