summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSpencer Oliver <ntfreak@users.sourceforge.net>2010-11-12 11:41:55 +0000
committerSpencer Oliver <ntfreak@users.sourceforge.net>2010-11-18 14:05:56 +0000
commit838cd58e24a18102b8a140df9fa993fe65706828 (patch)
tree1bac7c3ed5ffb83ae561b4b832d5661da735e68f /src/Makefile.am
parentab263fafbb5ed7c0464e8cfefc2f95095aa3e7cd (diff)
downloadopenocd+libswd-838cd58e24a18102b8a140df9fa993fe65706828.tar.gz
openocd+libswd-838cd58e24a18102b8a140df9fa993fe65706828.tar.bz2
openocd+libswd-838cd58e24a18102b8a140df9fa993fe65706828.tar.xz
openocd+libswd-838cd58e24a18102b8a140df9fa993fe65706828.zip
build: add common.mk
Rather than specifying common makefile variables move them all to a common.mk. Signed-off-by: Spencer Oliver <ntfreak@users.sourceforge.net>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 19a0ba96..c2d37c10 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,5 @@
+include $(top_srcdir)/common.mk
+
SUBDIRS = \
jtag \
helper \
@@ -29,12 +31,6 @@ noinst_HEADERS = \
hello.h \
openocd.h
-
-# set the include path found by configure
-AM_CPPFLAGS = \
- -I$(top_srcdir)/src \
- -I$(top_builddir)/src
-
libopenocd_la_CPPFLAGS = -DPKGBLDDATE=\"`date +%F-%R`\"
# banner output includes RELSTR appended to $VERSION from the configure script