summaryrefslogtreecommitdiff
path: root/src/helper/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-12-01 19:52:00 -0800
committerZachary T Welch <zw@superlucidity.net>2009-12-02 13:26:26 -0800
commiteaf10f69de969652d03742809b9c970158b90719 (patch)
treebb382e74018d2352a0ee05912d53c34b28ad6113 /src/helper/Makefile.am
parent34654359a918edae10ca7dd7ebc0a487fdf609a4 (diff)
downloadopenocd+libswd-eaf10f69de969652d03742809b9c970158b90719.tar.gz
openocd+libswd-eaf10f69de969652d03742809b9c970158b90719.tar.bz2
openocd+libswd-eaf10f69de969652d03742809b9c970158b90719.tar.xz
openocd+libswd-eaf10f69de969652d03742809b9c970158b90719.zip
remove BUILD_IOUTIL symbol
Add ioutil_stubs.c to provide an empty ioutil_init() routine. Add ioutil.h to prevent applications from needing to declare it. Allows unconditionally calling that function during startup, and the resulting libocdhelper library API is now more stable. Prints a DEBUG message when the stub implementation is included.
Diffstat (limited to 'src/helper/Makefile.am')
-rw-r--r--src/helper/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/helper/Makefile.am b/src/helper/Makefile.am
index 22b3c330..01e805eb 100644
--- a/src/helper/Makefile.am
+++ b/src/helper/Makefile.am
@@ -27,6 +27,8 @@ libhelper_la_SOURCES = \
if IOUTIL
libhelper_la_SOURCES += ioutil.c
+else
+libhelper_la_SOURCES += ioutil_stubs.c
endif
libhelper_la_CFLAGS =
@@ -38,6 +40,7 @@ endif
noinst_HEADERS = \
binarybuffer.h \
configuration.h \
+ ioutil.h \
types.h \
log.h \
command.h \