summaryrefslogtreecommitdiff
path: root/src/target/Makefile.am
diff options
context:
space:
mode:
authorZachary T Welch <zw@superlucidity.net>2009-11-17 08:29:20 -0800
committerZachary T Welch <zw@superlucidity.net>2009-11-18 07:21:42 -0800
commitcb7dbc1af41068f826246beb53870c01d8973bb8 (patch)
treeb32165dedbf769d667d0a3deeb86e4183f1bfb9e /src/target/Makefile.am
parent903daa796a226152fe56245758c8388b79d12988 (diff)
downloadopenocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.tar.gz
openocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.tar.bz2
openocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.tar.xz
openocd+libswd-cb7dbc1af41068f826246beb53870c01d8973bb8.zip
split startup.tcl file across modules
Moves definitions for each layer into their own file, eliminating layering violations in the built-in TCL code. Updates src/Makefile.am rules to include all files in the final startup.tcl input file, and others Makefile.am rules to distribute the new files in our packages.
Diffstat (limited to 'src/target/Makefile.am')
-rw-r--r--src/target/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/target/Makefile.am b/src/target/Makefile.am
index 9dd0bdc9..23aea82c 100644
--- a/src/target/Makefile.am
+++ b/src/target/Makefile.am
@@ -13,7 +13,9 @@ AM_CPPFLAGS = \
BIN2C = $(top_builddir)/src/helper/bin2char$(EXEEXT_FOR_BUILD)
DEBUG_HANDLER = $(srcdir)/xscale/debug_handler.bin
-EXTRA_DIST = $(DEBUG_HANDLER)
+EXTRA_DIST = \
+ startup.tcl \
+ $(DEBUG_HANDLER)
DEBUG_HEADER = xscale_debug.h
BUILT_SOURCES = $(DEBUG_HEADER)