summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dc4166d1..be42c283 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,9 +28,16 @@ Doxyfile: $(srcdir)/Doxyfile.in
sed -e 's,@srcdir\@,$(srcdir),' $< \
) > $@
+THE_MANUAL = doxygen/latex/refman.pdf
+
doxygen::
$(MAKE) Doxyfile
doxygen Doxyfile 2>&1 | perl $(srcdir)/tools/logger.pl > doxygen.log
+ $(MAKE) $(THE_MANUAL)
+
+%.pdf: %.tex
+ -cd $$(dirname $*) && pdflatex $$(basename $*)
+ -cd $$(dirname $*) && pdflatex $$(basename $*)
TCL_PATH = tcl
# command to find paths of script files, relative to TCL_PATH