summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index cb5277b7..10735f34 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,15 +11,23 @@ nobase_dist_pkgdata_DATA = \
SUBDIRS = src doc
-EXTRA_DIST = Doxyfile
+EXTRA_DIST = \
+ Doxyfile.in \
+ tools/logger.pl
docs: pdf html doxygen
+Doxyfile: $(srcdir)/Doxyfile.in
+ sed -e 's,@srcdir\@,$(srcdir),' $< > $@
+
doxygen::
- (cd $(srcdir) && doxygen Doxyfile 2>&1 | perl tools/logger.pl ) > doxygen.log
+ $(MAKE) Doxyfile
+ doxygen Doxyfile 2>&1 | perl $(srcdir)/tools/logger.pl > doxygen.log
+
+distclean-local:
+ rm -rf Doxyfile doxygen
-doxygen-clean:
- rm -f -r doxygen doxygen.log
+DISTCLEANFILES = doxygen.log
MAINTAINERCLEANFILES = \
configure \